Kunstmatige flats in photoshop

Uit Astrowiki
Ga naar: navigatie, zoeken

Inleiding[bewerken]

Deze kleine tutorial is bedoeld om grote soepele gradienten (bv. vignettering) te verwijderen met behulp van kunstmatige flats in photoshop. Als voorbeeld gebruik ik, met toestemming, een erg mooie foto van Andre (forumnaam: andre newton) uit Nieuweschans.

Als je een eigen foto gaat bewerken aan de hand van deze tutorial, zorg er dan voor dat je geen harde overgangen - zoals witte, zwarte, of grijze balken - of transparante delen in de foto hebt zitten. Als je deze artifacten wel in de foto hebt zitten, en je verwijdert deze niet eerst met een uitsnede (Crop Tool (C)), dan zijn deze ook na de volgende stappen nog altijd zichtbaar als een nieuwe duidelijke waas.

Als het onderwerp op de foto erg donker is, en je het wel wat lichter wilt maken, dan kan je dat met de curves tool (ctrl + m) het beste doen voordat je de kunstmatige flat gaat toepassen. Na afloop kan je de foto nog wel wat gaan bijwerken met levels en curves, maar het mooiste resultaat krijg je als je vooraf de foto al op een redelijke helderheid hebt gebracht. Doe dit trouwens altijd met mate, informatie die je nu weggooit door de foto te licht (of te donker) te maken krijg je later niet meer terug!

0 uitgangspositie klein.jpg

De foto van Andre is hier om practische redenenen verkleind tot 25% van de orginele grote.

Om tijdens het bewerken van foto's vervelende artifacts en verlies van detail tegen te gaan moet je in de eerste plaats altijd zorgen dat je minimaal in 16-bit/kanaal werkt (Image -> Mode -> 16-bit/Channel). Dus ook als je stiekem toch met een 8-bit JPEG aan de gang gaat (vanwege de JPEG compressie is dat natuurlijk wel verre van optimaal!)

Ik ga er vanaf nu vanuit dat de afbeelding is geopend in photoshop, en dat het een 16-bit/kanaal RGB afbeelding is.

Stap voor stap - voor elk kleur-kanaal[bewerken]

- Selecteer onder channels een kleur-kanaal waar je nog niet een kunstmatige flat op hebt toegepast (ctrl+1, ctrl+2, of ctrl+3, onder Channels).

1 channels.jpg

- Selecteer de hele afbeelding en kopieer deze in het werkgeheugen (ctrl+a, en dan ctrl+c) - Ga naar File -> New, en klik 'OK' om een nieuw bestand aan te maken - Plaats hierin tweemaal de afbeelding die in het wergeheugen zit (ctrl+v, ctrl+v)

Als het goed is heb je nu helemaal onderaan in je layer lijstje een 'Background' layer staan, en daarboven twee layers 'Layer 1' en 'Layer 2'. De background layer mag je in principe compleet negeren, maar zelf heb ik de onderste twee layers even samengevoegd: selecteer beide layers met behulp van de CTRL knop en de linkermuisknop, en klik met de rechtermuisknop op deze selectie en kies voor 'Merge Layers'. Hierdoor krijg je een nieuwe 'Background' layer, met daarboven 'Layer 2'.

2 newimage.jpg


- Selecteer nu de bovenste layer, Layer 2, en ga naar Filter -> Noise -> Dust & Scratches, en verwijder zoveel mogelijk sterren maar hou de achtergrond een beetje korrelig (door met de threshold te spelen). Klik op Ok.

3 dust scratches.jpg


- Selecteer de clone-stamp tool (S), en ga met een niet al te kleine brush de sterrenstelsels en andere overblijfselen wegpoetsen. Werk met de gradient mee (volg dus een rand van de gradient, anders verplaats je de gradient). Dit proces komt niet zo heel nauwkeurig; zorg er in ieder geval voor dat je geen kleine heldere vlekken meer hebt, en dat het geheel er egaal uitzit (als je wazig kijkt).

4 bijwerken clonetool.jpg


- Pas een Gaussian blur toe via Filter -> Blur. Welke radius je moet gebruiken hangt een beetje af van de grootte van de afbeelding, maar ga uit van iets rond de 15 tot 30 voor een klein bestand ( < 1mpixel), en 30-60 voor een groot bestand (>> 1mpixel).

5 gaussian blur.jpg


- Inverteer nu de (nog altijd geselecteerde bovenste layer) met CTRL + i. De afbeelding krijgt nu een tegenovergestelde gradient (moeilijk te zien).

6 inverse.jpg


- En zet vervolgens de opacity van de bovenste layer op 50%. De sterren, en sterrenstelsels van de layer daaronder worden daardoor ook weer zichtbaar, maar de afbeelding is nog vrij licht. De gradient is nu al wel verdwenen.

7 opacity.jpg


- Flatten nu deze hele afbeelding onder Layer -> Flatten Image (of rechtermuisknop op een van de layers klikken, en daar kiezen voor Flatten Image). Je hebt nu nog maar een enkele 'Background' layer over. Met behulp van de levels tool (ctrl+L) moet je nu de shadow input level omhoog zetten (naar meestal rond de 120-128). De afbeelding zal er hierdoor weer 'normaal' donker uit gaan zien.

8 levels.jpg


- Als je tevreden bent met het niveau van de achtergrond dan kan je het kleurkanaal terug kopieeren in het orginele kleurenbestand. Doe ctrl + a, gevolgd door ctrl + c om de het bewerkte kleurkanaal in het geheugen te plaatsen, en selecteer nu de orginele afbeelding (met de drie kleurkanalen). Selecteer hierin het juiste kleurkanaal (ctrl + 1, ctrl + 2, of ctrl + 3, of kijk onder Channels). Plak het bewerkte kleurkanaal nu over de oude heen met ctrl + v.

De overige kleurkanalen moet je op dezelfde manier bewerken.

Let goed op de donkerte van de ruimte. Hou dit constant voor alle kleurkanalen (anders krijg je een rode, blauwe of groene zweem over de foto), dit kan je ook nog prima aan het eind van de rit bijstellen - als je op elk kleurkanaal een kunstmatige flat hebt toegepast - met de levels tool.

Het mag duidelijk zijn dat dit slechts een van de vele manieren is om dit in photoshop voor elkaar te krijgen, maar dit is de manier die ik mezelf heb aangeleerd, en het werkt op deze manier vrij behoorlijk.

Resultaat[bewerken]

Het eindresultaat van deze bewerkingen ziet er zo uit. De kleur is nog een klein beetje opgepoetst in LAB-kleuren mode, maar daarover wellicht later meer...

9 eindresultaat.jpg

Deze tutorial is geschreven door Emil (MvZ)